en:doku:install

Installation & First start

The Gordons Reloading Tool (GRT) is a portable Software and is delivered in an archive. The archive contains all necessary files and components.

IMPORTANT: The archive file has to be extracted before you can start GRT! You cannot start GRT within the archive!

EXTRACT the archive into a folder of your choice, e.g. onto “C:\” It is also possible to copy the unpacked archive to a thumb drive and run the program from there.

Settings that you make in the program are stored in the file GordonsReloadingTool.cfg in the program directory of the GRT.

The GRT archive file usually has the following structure (using Windows as an example):

  • GordonsReloadingTool-<version>
    • /doku - Directory for documentation files and templates used by the program.
    • /libs - Directory of program libraries
    • /loads - Directory of (sample) laboratory files/loaded data files
    • /Resources - Directory of program language files
    • GordonsReloadingTool.cfg - Configuration file, in this file the program saves its settings.
    • GordonsReloadingTool.db - local Database
    • GordonsReloadingTool.exe - program file
    • LICENSE.TXT - License (english)
    • LIESMICH.TXT
    • LIZENZ.TXT - Original License (german)
    • README.TXT
Resolution: HD 1080p
Memory: 100 MB
Work Memory (RAM): 1 GB
Operating system: Windows or Linux (x86/x86_64)

Windows:

Windows 7 SP1, Vista, 8.1, 10 in 32 or 64 Bit.

Linux:

  • Recommended: Linux Mint 20 - 64 Bit (Debian)

It may be necessary to install required dependencies (execute commands one after the other):

$ sudo dpkg --add-architecture i386
$ sudo apt-get update
$ sudo apt-get install lib32stdc++6
$ sudo apt-get install libgtk2.0-0:i386
$ sudo apt-get install gtk2-engines-pixbuf:i386
$ sudo apt-get install gtk2-engines-murrine:i386
$ sudo apt-get install gnome-themes-extra:i386
$ sudo apt-get install libcurl4-openssl-dev:i386

If you want to identify necessary libraries, the command ldd can help. You can run this command from Terminal in the GordonsReloadingTool directory to return a list of the libraries required by the GordonsReloadingTool and their status on the system:

ldd GordonsReloadingTool
Please note:

GRT is not developed under Linux, so it is a cross-compiled application and is only tested extensively with the recommended system mentioned above. If you have problems running GRT on your distribution, please consult your Linux help on how to run Standard 32-bit Gtk applications on your specific distribution.

This website uses only functional necessary cookies.

By clicking on OK, you agree with storing that cookies on your computer for the time of your session. If you do not agree please leave the website.

Show information about the used cookies.

Show our policies.

  • en/doku/install.txt
  • Last modified: 2021/05/30 03:34
  • (external edit)